hdu1010:Tempter of the Bone(dfs)


http://acm.hdu.edu.cn/showproblem.php?pid=1010

Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0

Sample Output

NO
YES

题意分析:

S代表小狗,D代表门,X代表墙,走过的地板不能再走,问小狗能不能到达门正好走t步。

#include <stdio.h>
#include <string.h> 
#define N 10
char a[N][N];
int book[N][N],next[4][2]={1,0, 0,1, -1,0, 0,-1};
int n, m, t, temp;
void dfs(int i, int j, int s)
{
	int tx, ty, k;
	if(s>t || temp==1)
		return ;
	if(a[i][j]=='D')
	{
		if(s==t)
			temp=1;
		return ;
	}
	for(k=0; k<4; k++)
	{
		tx=i+next[k][0];
		ty=j+next[k][1];
		if(a[tx][ty]!='X' && book[tx][ty]==0 && tx>=0 && ty>=0 && tx<n && ty<m)
		{
			book[tx][ty] = 1;
			dfs(tx, ty, s+1);
			book[tx][ty] = 0;
		}
	}
}
int main()
{
	int i, j;
	while(scanf("%d%d%d", &n, &m, &t)!=EOF)
	{
		memset(book, 0, sizeof(book));
		if(n==0 && m==0 && t==0)
			break;
		for(i=0; i<n; i++)
			scanf("%s", a[i]);
		temp = 0;
		for(i=0; i<n; i++)
			for(j=0; j<m; j++)
				if(a[i][j]=='S')
				{
					book[i][j] = 1;
					dfs(i, j, 0);
					break;
				}
		if(temp == 1)
			printf("YES\n");
		else
			printf("NO\n");				
	}
	return 0;
}

优质内容筛选与推荐>>
1、Web 文件上传 目录
2、爬取全部的校园新闻
3、ubuntu16.04+Pangolin安装
4、java 并发synchronized使用
5、阻塞与非阻塞、同步与异步、I/O模型


长按二维码向我转账

受苹果公司新规定影响,微信 iOS 版的赞赏功能被关闭,可通过二维码转账支持公众号。

    阅读
    好看
    已推荐到看一看
    你的朋友可以在“发现”-“看一看”看到你认为好看的文章。
    已取消,“好看”想法已同步删除
    已推荐到看一看 和朋友分享想法
    最多200字,当前共 发送

    已发送

    朋友将在看一看看到

    确定
    分享你的想法...
    取消

    分享想法到看一看

    确定
    最多200字,当前共

    发送中

    网络异常,请稍后重试

    微信扫一扫
    关注该公众号