A -Agri-Net Time Limit:1000MSMemory Limit:10000KB64bit IO Format:%I64d & %I64u
SubmitStatusPracticePOJ 1258

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

prim:

#include<stdio.h>
int main(){
int tre[102][102];
int n;
while(~scanf("%d",&n)){
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++){
scanf("%d",&tre[i][j]);
}
int min[102]={0};
int sum=0;int cmp;int mi=1000000;
min[1]=1;//1表示点被连进来了
int minsum[102];
for(int r=1;r<=n;r++){
minsum[r]=tre[1][r];
}
for(int k=1;k<=n-1;k++)
{
	mi=1000000;
	for(int t=1;t<=n;t++){
		if(min[t]!=1&&minsum[t]>0&&minsum[t]<mi){
		cmp=t;
		mi=minsum[t];//得到min
		}
	}
	sum+=mi;
	min[cmp]=1;//该点被连接
	//进行更新
for(int yy=1;yy<=n;yy++)
{
	if(min[yy]==1){
		for(int hh=1;hh<=n;hh++){
			if(min[hh]!=1){
			if(tre[yy][hh]<minsum[hh])
				minsum[hh]=tre[yy][hh];
			}
		
		}
	}

}


}
printf("%d\n",sum);
}
return 0;
}





长按二维码向我转账

受苹果公司新规定影响,微信 iOS 版的赞赏功能被关闭,可通过二维码转账支持公众号。

    阅读
    好看
    已推荐到看一看
    你的朋友可以在“发现”-“看一看”看到你认为好看的文章。
    已取消,“好看”想法已同步删除
    已推荐到看一看 和朋友分享想法
    最多200字,当前共 发送

    已发送

    朋友将在看一看看到

    确定
    分享你的想法...
    取消

    分享想法到看一看

    确定
    最多200字,当前共

    发送中

    网络异常,请稍后重试

    微信扫一扫
    关注该公众号





    联系我们

    欢迎来到TinyMind。

    关于TinyMind的内容或商务合作、网站建议,举报不良信息等均可联系我们。

    TinyMind客服邮箱:support@tinymind.net.cn