poj 2931 Building a Space Station <克鲁斯卡尔>


Building a Space Station

Time Limit: 1000MS

Memory Limit: 30000K

Total Submissions: 5869

Accepted: 2910

Description

You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task.
The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible.

All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor', or (3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively.

You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with the shortest total length of the corridors.

You can ignore the width of a corridor. A corridor is built between points on two cells' surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect.

Input

The input consists of multiple data sets. Each data set is given in the following format.

n
x1 y1 z1 r1
x2 y2 z2 r2
...
xn yn zn rn

The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100.

The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after the decimal point. Values are separated by a space character.

Each of x, y, z and r is positive and is less than 100.0.

The end of the input is indicated by a line containing a zero.

Output

For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001.

Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000.

Sample Input

3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0

Sample Output

20.000
0.000
73.834

Source

Japan 2003 Domestic
题意:
首先输入一个数n。代表空间站的个数。然后输入n行数,每行4个数(double型)。分别相应那个空间站的坐标(x,y,z),和它的半径(由于空间站是圆形的,所以会有半径),然后题目要求是让在每一个空间站间安装一个走廊。能够从随意一个空间站到另外一个。也就是构造最小生成树。(可是须要注意的是这是圆形的你算过圆心之间的距离之后还须要将两个半径减去,才是须要修的走廊的长度,而且假设两个圆心之间的距离有可能小于两个半径之和,这个你就须要另外处理,将他处理成0即可了,不能是负数,由于走廊的长度不会是负数)。
思路:
先将随意两点的之间的距离(减去两个半径)求出来,然后将他们进行排序,用克鲁斯卡尔算法求解即可了!(记住距离不能是负数。假设求的是负数,就将其改成0)。
代码:
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int n;
double x[105];
double y[105];
double z[105];
double r[105];
int pre[105];
struct node 
{
	int u,v;
	double w; 
}map[10005];
int cmp(node a,node b)
{
	return a.w<b.w;
}
void init()
{

}
int find(int x)
{
	int r=x;
	while(r!=pre[r])
	{
		r=pre[r];
	}
	int i,j;
	i=x;
	while(i!=r)
	{
		j=pre[i];
		pre[i]=r;
		i=j;
	}
	return r;
}
int join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		pre[fx]=fy;
		return 1;
	}
	return 0;
}
int main()
{
    
	while(scanf("%d",&n)&&n)
	{
	   	for(int i=1;i<=101;i++)
	    {
		pre[i]=i;
	    }
		
		for(int i=1;i<=n;i++)
	    {
		scanf("%lf%lf%lf%lf",&x[i],&y[i],&z[i],&r[i]);
	    }
		int t=0;
		double d;
		for(int i=1;i<n;i++)
		{
			for(int j=i+1;j<=n;j++)
			{
				t++;
				map[t].u=i;
				map[t].v=j;
				d=sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j])+(z[i]-z[j])*(z[i]-z[j]));//三维坐标求距离!

if(d<(r[i]+r[j]))//这一点须要特殊粗粒 map[t].w=0; else map[t].w=d-(r[i]+r[j]); } } sort(map+1,map+t+1,cmp); double sum=0; for(int i=1;i<=t;i++) { if(join(map[i].u,map[i].v)) { sum+=map[i].w; } } printf("%.3f\n",sum);//注意输出的时候,这一道 题有个坑。就是必须用%f输出! } return 0; }


优质内容筛选与推荐>>
1、React Native ScrollView 添加图片数组
2、jvm面试题
3、先记录一下自己最近的积累吧(XSL+XML导出及JS对XML的操作)
4、【hihocoder 1499】A Box of Coins
5、[Objective-c 基础 - 3.3] block数据类型


长按二维码向我转账

受苹果公司新规定影响,微信 iOS 版的赞赏功能被关闭,可通过二维码转账支持公众号。

    阅读
    好看
    已推荐到看一看
    你的朋友可以在“发现”-“看一看”看到你认为好看的文章。
    已取消,“好看”想法已同步删除
    已推荐到看一看 和朋友分享想法
    最多200字,当前共 发送

    已发送

    朋友将在看一看看到

    确定
    分享你的想法...
    取消

    分享想法到看一看

    确定
    最多200字,当前共

    发送中

    网络异常,请稍后重试

    微信扫一扫
    关注该公众号





    联系我们

    欢迎来到TinyMind。

    关于TinyMind的内容或商务合作、网站建议,举报不良信息等均可联系我们。

    TinyMind客服邮箱:support@tinymind.net.cn