HDU 1564 Play a game (找规律博弈)


Play a game

Time Limit: 1000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1030Accepted Submission(s): 838


Problem Description
New Year is Coming!
ailyanlu is very happy today! and he is playing a chessboard game with 8600.
The size of the chessboard is n*n. A stone is placed in a corner square. They play alternatively with 8600 having the first move. Each time, player is allowed to move the stone to an unvisited neighbor square horizontally or vertically. The one who can't make a move will lose the game. If both play perfectly, who will win the game?

Input
The input is a sequence of positive integers each in a separate line.
The integers are between 1 and 10000, inclusive,(means 1 <= n <= 10000) indicating the size of the chessboard. The end of the input is indicated by a zero.

Output
Output the winner ("8600" or "ailyanlu") for each input line except the last zero.
No other characters should be inserted in the output.

Sample Input
2 0

Sample Output
8600

Author
ailyanlu

Source
Happy 2007

Recommend
8600

从一个n*n的角落出发,每次移动到相邻的,而且没有经过的格子上。谁不能操作了谁输。

结论就是n为偶数,先手赢,奇数,后手赢。

可以看下图

S表示起点。

如果n为偶数,那么所有格子可以被2*1的砖块覆盖掉。

这样先手每次都移动到当前1*2的另外一块。先手必赢。

如果n为奇数。出了起始那个店,其余点都可以被覆盖。

所有后手赢

#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <iostream>
using namespace std;
int main()
{
    int n;
    while(scanf("%d",&n)==1 &&n)
    {
        if(n%2==0)printf("8600\n");
        else printf("ailyanlu\n");
    }
    return 0;
}

优质内容筛选与推荐>>
1、IntelliJ IDEA —— Android开发的另一个选择
2、Toad for mysql
3、分享Kali Linux 2016.2第48周虚拟机
4、微服务架构知识及工程实践
5、zabbix--告警触发器配置,防止误报


长按二维码向我转账

受苹果公司新规定影响,微信 iOS 版的赞赏功能被关闭,可通过二维码转账支持公众号。

    阅读
    好看
    已推荐到看一看
    你的朋友可以在“发现”-“看一看”看到你认为好看的文章。
    已取消,“好看”想法已同步删除
    已推荐到看一看 和朋友分享想法
    最多200字,当前共 发送

    已发送

    朋友将在看一看看到

    确定
    分享你的想法...
    取消

    分享想法到看一看

    确定
    最多200字,当前共

    发送中

    网络异常,请稍后重试

    微信扫一扫
    关注该公众号





    联系我们

    欢迎来到TinyMind。

    关于TinyMind的内容或商务合作、网站建议,举报不良信息等均可联系我们。

    TinyMind客服邮箱:support@tinymind.net.cn