Winter-2-STL-F Ananagrams 解题报告及测试数据


Time Limit:3000MS Memory Limit:0KB Description Most crossword puzzle fans are used to anagrams--groups of words with the same letters in different orders--for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ. Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE. Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be ``rearranged'' at all. The dictionary will contain no more than 1000 words. Input Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus tIeD and EdiT are anagrams. The file will be terminated by a line consisting of a single #. Output Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram. Sample input ladder came tape soon leader acme RIDE lone Dreis peat ScAlE orb eye Rides dealer NotE derail LaCeS drIed noel dire Disk mace Rob dries # Sample output Disk NotE derail drIed eye ladder soon

题解:

  1. 去掉输入过程中重复的单词,需要对统一小写后的单词排序,例如 aab cdf frf aabAaB,小写排序后是aab aab aabcad frf,那么很容易遍历一遍进行标记,将输入重复的单词只保留一个。

  2. ​寻找回文,例如adc cda utg 三个单词,对每一个单词进行字母排序后再整体排序,排序结果是:acd acd gtu,出现次数大于一次的很显然是回文,那么和上面一样,很容易遍历2遍后将出现次数大于一次的单词去掉。最后剩下的就是非回文。然后对非回文进行排序输出即可。

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cctype>
using namespace std;
string ss[10000];
char s[100];
int k,k2,tag[10000];
struct Node{
    string ori,low,sor;//ori原始输入,low小写处理,sor字母排序
}str[10000];
bool cmp1(Node a,Node b){//按照小写后单词进行排序处理
    return a.low < b.low;
}
bool cmp2(Node a,Node b){//按照字母排序后的单词排序处理
    return a.sor < b.sor;
}
void set(Node&b,Node&a){//赋值操作
    b.ori =  a.ori;b.low = a.low;b.sor=a.sor;
}
int main(){
    //freopen("1.in","r",stdin);
    while(scanf("%s",s)!=EOF && s[0]!='#'){
        str[k].ori = s;
        for(int i=0;s[i];i++)s[i]=tolower(s[i]);
        str[k].low = s ;//小写
        sort(s,s+strlen(s));
        str[k++].sor = s;//排序
    }
        //对小写后的单词进行排序,目的是去除输入过程中重复的单词
    sort(str,str+k,cmp1);
    string pre = "";
    for(int i=0;i<k;i++){
        if(str[i].low == pre)tag[i]=1;
        pre = str[i].low;
    }
    for(int i=0;i<k;i++){
        if(!tag[i])set(str[k2++],str[i]);
        else tag[i]=0;
    }
        //对字母排序后的单词排序,目的是寻找回文单词
    k = k2;
    sort(str,str+k,cmp2);
    pre = "";
    for(int i=0;i<k;i++){
        if(str[i].sor == pre)tag[i]=1;
        pre = str[i].sor;
    }
    for(int i=0;i<k;i++)
        if(tag[i])tag[i-1]=1;
    k2=0;
    for(int i=0;i<k;i++)
        if(!tag[i])ss[k2++]=str[i].ori;
        //最后对原始输入排序输出。
    sort(ss,ss+k2);
    for(int i=0;i<k2;i++)
        cout << ss[i]<<endl;
}

  

优质内容筛选与推荐>>
1、DNN开发:
2、SSE图像算法优化系列八:自然饱和度(Vibrance)算法的模拟实现及其SSE优化(附源码,可作为SSE图像入门,Vibrance算法也可用于简单的肤色调整)。
3、Redux状态管理方法与实例
4、学习jQuery(一),做的第一个可拖动列的Grid
5、分布式文件系统应用(下篇 实践)


长按二维码向我转账

受苹果公司新规定影响,微信 iOS 版的赞赏功能被关闭,可通过二维码转账支持公众号。

    阅读
    好看
    已推荐到看一看
    你的朋友可以在“发现”-“看一看”看到你认为好看的文章。
    已取消,“好看”想法已同步删除
    已推荐到看一看 和朋友分享想法
    最多200字,当前共 发送

    已发送

    朋友将在看一看看到

    确定
    分享你的想法...
    取消

    分享想法到看一看

    确定
    最多200字,当前共

    发送中

    网络异常,请稍后重试

    微信扫一扫
    关注该公众号





    联系我们

    欢迎来到TinyMind。

    关于TinyMind的内容或商务合作、网站建议,举报不良信息等均可联系我们。

    TinyMind客服邮箱:support@tinymind.net.cn