HDU 1541 star (树状数组)


Stars

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5400Accepted Submission(s): 2133


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input
5 1 1 5 1 7 1 3 3 5 5

Sample Output
1 2 1 1 0

Source
Ural Collegiate Programming Contest 1999

题目大意:

  给你n个点,这n个点的输入是按照y递增的顺序输入的,让你求出每个点左下角有多少个点。

解题思路:

  看到后,就想到了BIT,因为至少有15000个点需要我们来维护,如果每次插入一个点,然后再去用O(n^2)去处理的话,肯定会很慢,于是我们就想到了

用BIT来维护了。但是,BIT中的tree[]必须是从1开始的,所以我们必须要对于所有的横坐标都预处理下,相当于把坐标系向左平移一个单位,这样一来,我们就不用担心x=0,的情况了,一开始tree[]中的所有元素都是0,而这个数组的长度就是x的最大值,因为我们可以假设最坏的情况下,所有的x的值都有可能取到。然后,我们每次新增加一个点,我们就去判断这个点的前面有多少个点,因为y是按照递增的顺序插入的,所以已经满足了左下角的要求了,每次插入一个点,就在相应的x上加1。

最后统计每个x上的点的个数就好了。。。

代码:

# include<cstdio>
# include<iostream>
# include<fstream>
# include<algorithm>
# include<functional>
# include<cstring>
# include<string>
# include<cstdlib>
# include<iomanip>
# include<numeric>
# include<cctype>
# include<cmath>
# include<ctime>
# include<queue>
# include<stack>
# include<list>
# include<set>
# include<map>

using namespace std;

const double PI=4.0*atan(1.0);

typedef long long LL;
typedef unsigned long long ULL;

# define inf 999999999
# define MAX 32000+5

int ans[MAX];
int tree[MAX];

int read( int pos )
{
    int sum = 0;
    while ( pos > 0 )
    {
        sum+=tree[pos];
        pos-=pos&(-pos);
    }
    return sum;
}

void update( int pos,int val )
{
    while ( pos <= MAX )
    {
        tree[pos]+=val;
        pos+=pos&(-pos);
    }
}


int main(void)
{
    int n;
    while ( cin>>n )
    {
        memset(tree,0,sizeof(tree));
        memset(ans,0,sizeof(ans));
        int x,y;
        for ( int i = 0;i < n;i++ )
        {
            cin>>x>>y;
            x++;
            ans[read(x)]++;
            update(x,1);
        }

        for ( int i = 0;i < n;i++ )
        {
            cout<<ans[i]<<endl;
        }

    }





    return 0;
}
View Code

优质内容筛选与推荐>>
1、MVC3 带查询的分页Helper
2、AutoCAD中的螺旋究竟是什么螺旋?
3、javadoc注释的初级用法
4、vue基于 element ui 的按钮点击节流
5、汇编四(习题)


长按二维码向我转账

受苹果公司新规定影响,微信 iOS 版的赞赏功能被关闭,可通过二维码转账支持公众号。

    阅读
    好看
    已推荐到看一看
    你的朋友可以在“发现”-“看一看”看到你认为好看的文章。
    已取消,“好看”想法已同步删除
    已推荐到看一看 和朋友分享想法
    最多200字,当前共 发送

    已发送

    朋友将在看一看看到

    确定
    分享你的想法...
    取消

    分享想法到看一看

    确定
    最多200字,当前共

    发送中

    网络异常,请稍后重试

    微信扫一扫
    关注该公众号





    联系我们

    欢迎来到TinyMind。

    关于TinyMind的内容或商务合作、网站建议,举报不良信息等均可联系我们。

    TinyMind客服邮箱:support@tinymind.net.cn