USACO Problem 77:Greedy Gift Givers解题报告


Greedy Gift Givers

A group of NP (2 ≤ NP ≤ 10) uniquely named friends has decided to exchange gifts of money. Each of these friends might or might not give some money to any or all of the other friends. Likewise, each friend might or might not receive money from any or all of the other friends. Your goal in this problem is to deduce how much more money each person gives than they receive.

The rules for gift-giving are potentially different than you might expect. Each person sets aside a certain amount of money to give and divides this money evenly among all those to whom he or she is giving a gift. No fractional money is available, so dividing 3 among 2 friends would be 1 each for the friends with 1 left over -- that 1 left over stays in the giver's "account".

In any group of friends, some people are more giving than others (or at least may have more acquaintances) and some people have more money than others.

Given a group of friends, no one of whom has a name longer than 14 characters, the money each person in the group spends on gifts, and a (sub)list of friends to whom each person gives gifts, determine how much more (or less) each person in the group gives than they receive.

IMPORTANT NOTE

The grader machine is a Linux machine that uses standard Unix conventions: end of line is a single character often known as '\n'. This differs from Windows, which ends lines with two charcters, '\n' and '\r'. Do not let your program get trapped by this!

PROGRAM NAME: gift1

INPUT FORMAT

Line 1: The single integer, NP
Lines 2..NP+1: Each line contains the name of a group member
Lines NP+2..end: NP groups of lines organized like this:
The first line in the group tells the person's name who will be giving gifts.
The second line in the group contains two numbers: The initial amount of money (in the range 0..2000) to be divided up into gifts by the giver and then the number of people to whom the giver will give gifts, NGi(0 ≤ NGi≤ NP-1).
If NGiis nonzero, each of the next NGilines lists the the name of a recipient of a gift.

SAMPLE INPUT (file gift1.in)

5  dave  laura  owen  vick  amr  dave  200 3  laura  owen  vick  owen  500 1  dave  amr  150 2  vick  owen  laura  0 2  amr  vick  vick  0 0  

OUTPUT FORMAT

The output is NP lines, each with the name of a person followed by a single blank followed by the net gain or loss (final_money_value - initial_money_value) for that person. The names should be printed in the same order they appear on line 2 of the input.

All gifts are integers. Each person gives the same integer amount of money to each friend to whom any money is given, and gives as much as possible that meets this constraint. Any money not given is kept by the giver.

SAMPLE OUTPUT (file gift1.out)

dave 302  laura 66  owen -359  vick 141  amr -150  
****************************************************************************************************

贪婪的礼物送礼者

by tim green

对于一群要互送礼物的朋友,你要确定每个人送出的礼物比收到的多多少(and vice versa for those who view gift giving with cynicism)
在这一个问题中,每个人都准备了一些钱来送礼物,而这些钱将会被平均分给那些将收到他的礼物的人。
然而,在任何一群朋友中,有些人将送出较多的礼物(可能是因为有较多的朋友),有些人有准备了较多的钱。
给出一群朋友, 没有人的名字会长于 14 字符,给出每个人将花在送礼上的钱,和将收到他的礼物的人的列表,
请确定每个人收到的比送出的钱多的数目。

IMPORTANT NOTE

测试系统是 Linux 符合标准的 Unix 的协定。
'\n'作为行的结束。
这和 Windows 系统用'\n' '\r'作为行的结束是不同的。
你的程序不要被这困住了。

PROGRAM NAME: gift1

INPUT FORMAT

1 :

人数NP,2<= NP<=10

2NP+1 :

NP个在组里人的名字 一个名字一行

NP2到最后:

这里的NP段内容是这样组织的:
第一行是将会送出礼物人的名字。
第二行包含二个数字: 第一个是原有的钱的数目(在02000的范围里),第二个NGi是将收到这个送礼者礼物的人的个数 如果 NGi 是非零的, 在下面 NGi 行列出礼物的接受者的名字,一个名字一行。

SAMPLE INPUT (file gift1.in)

5
dave
laura
owen
vick
amr
dave
200 3
laura
owen
vick
owen
500 1
dave
amr
150 2
vick
owen
laura
0 2
amr
vick
vick
0 0

OUTPUT FORMAT

输出 NP
每行是一个的名字加上空格再加上收到的比送出的钱多的数目。
对于每一个人,他名字的打印顺序应和他在输入的2NP1行中输入的顺序相同。所有的送礼的钱都是整数。
每个人把相同数目的钱给每位要送礼的朋友,而且尽可能多给,不能给出的钱被送礼者自己保留。

SAMPLE OUTPUT (file gift1.out)

dave 302
laura 66
owen -359
vick 141
amr -150

********************************************************************************************************

这水题对于骨灰级菜鸟的我,这读题就有种想死的感觉了....代码..

以前做题都没用过类,这次用一下 思路挺清晰的,就是后面数组没开大弄了挺久,囧...

/*
ID: jun41821
PROG: gift1
LANG: C++
*/
#include <iostream>
#include <fstream>
#include <cstring>
using namespace std;
class friends{
public:
string name;
int menoy;
friends()
{
menoy=0;
}
};
int main()
{
ofstream fout ("gift1.out");
ifstream fin ("gift1.in");
friends person[15];
int NP,i,N,M,j,k;
char name1[20][20];
fin>>NP;
for(i=0;i<NP;i++)
{
fin>>person[i].name;
}
for(k=0;k<NP;k++)
{
memset(name1,0,sizeof(name1));
fin>>name1[0];
fin>>N>>M;
if(N==0&&M==0)
continue;
for(i=1;i<=M;i++)
{
fin>>name1[i];
}
for(i=0;i<NP;i++)
{
if(person[i].name==name1[0]) //处理送礼物的人
{
person[i].menoy-=N;
person[i].menoy+=N%M;
cout<<N%M<<endl;
}
}
for(i=1;i<=M;i++) //处理收礼物的人
{
for(j=0;j<NP;j++)
if(name1[i]==person[j].name)
{
person[j].menoy+=N/M;
}
}

}
for(i=0;i<NP;i++)
{
fout<<person[i].name<<' '<<person[i].menoy<<endl;
}

return 0;
}

优质内容筛选与推荐>>
1、C#各版本特性
2、【转载】Fiddler 抓包工具使用指北: 弱网络环境模拟限速测试流程
3、deeplearning.ai 旁听如何做课后编程作业
4、WordNet词网研究7——之JWS(Java Wordnet Similarity)语义相似度计算
5、区别


长按二维码向我转账

受苹果公司新规定影响,微信 iOS 版的赞赏功能被关闭,可通过二维码转账支持公众号。

    阅读
    好看
    已推荐到看一看
    你的朋友可以在“发现”-“看一看”看到你认为好看的文章。
    已取消,“好看”想法已同步删除
    已推荐到看一看 和朋友分享想法
    最多200字,当前共 发送

    已发送

    朋友将在看一看看到

    确定
    分享你的想法...
    取消

    分享想法到看一看

    确定
    最多200字,当前共

    发送中

    网络异常,请稍后重试

    微信扫一扫
    关注该公众号