HDU 2451 Simple Addition Expression


Simple Addition Expression

Time Limit: 5000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1508Accepted Submission(s): 576


Problem Description
A luxury yacht with 100 passengers on board is sailing on the sea in the twilight. The yacht is ablaze with lights and there comes out laughers and singing from the hall where an evening party is in full swing. People are singing, dancing and enjoying themselves.

The yacht is equipped with the most advanced navigation and driving system which can all be manipulated by a computer. When the captain notices that there is only gentle breeze and the sea waves are not high, he starts the autopilot. The yacht sails forward smoothly, ploughs the waves. When it’s completely dark, the passengers start to feel a little funny for sudden forward rushes or sudden decelerations or slight swings. The captain immediately walks to the driving platform and switches the autopilot to human manipulation. The yacht returns back to normal and the party restarts. Laughers come back, too.

The captain summons the engineer on board to do a thorough check of the navigation system. It turns out that only the computer is out of order, but the exact failure is still unclear. There is a computer scientist among the passengers who is also invited to the cab to give a hand. He first inputs several groups of data to test the computer. When he inputs 1+2+3, the computer outputs 6, which is exactly right. But when he inputs 4+5+6, the computer outputs 5, which is wrong. Then he inputs 12+13+14, and gets 39, another right answer, while he inputs 14+15+16, and gets 35, another wrong answer. After the test, the computer scientist says smilingly: “the failure is clear now. The computer's adder can not carry." After excluding the failure, the captain restarts the autopilot and the yacht returns back to normal, sailing smoothly on the sea.

The captain and the engineer invite the computer scientist to sit down and have a talk. The computer scientist tells a story as following:

A former mathematician defined a kind of simple addition expression.
If there is an expression (i) + (i+1) + (i+2), i>=0, when carried out additive operations, no position has a carry, it is called simple addition expression.

For instance, when i equals 0, 0+1+2 is a simple addition expression, meanwhile when i equals 11, 11+12+13 is a simple addition expression, too. Because of that no position has a carry.

However, when i equals 3, 3+4+5 is not a simple addition expression, that is because 3+4+5 equals 12, there is a carried number from unit digit to tens digit. In the same way, when i equals 13, 13+14+15 is not a simple addition expression, either. However, when i equals 112, 112+113+114 is a simple addition expression. Because 112+113+114 equals 339, there is no carry in the process of adding.

when the students have got the definition of simple addition expression, the mathematician puts forward a new question: for a positive integer n, how many simple addition expressions exist when i<n. In addition, i is the first number of a simple addition expression.

when the value of n is large enough, the problem needs to be solved by means of computer.

Input
There are several test cases, each case takes up a line, there is an integer n (n<10^10).

Output
Output the number of all simple addition expressions when i<n.

Sample Input
1 2 3 4 10 11
Sample Output
1 2 3 3 3 4

题意是要判断前n位数字(不包括n),有多少个数字 i 跟前面两个 i+1 , i+2 ,相加时不进位 。

符合要求的数字就是个位 0 ~ 2 ,其余位 0 ~ 3。

用一个dfs就可以搜出来了。

对于当前位是 x 的话 , 若果 x > 3 , 可以直接得出可以构成 [ 4^(位数-1) * 3 ] 个数

若果 x <= 3 的话 , 就可以构成 [ (x-1)*4^(位数-1)*3 + 后面的位能组成数字的数目(递归求) ]。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <algorithm>
using namespace std;
#define root 1,n,1
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
#define lr rt<<1
#define rr rt<<1|1
typedef long long LL;
const int oo = 1e9+7;
const double PI = acos(-1.0);
const double eps = 1e-6 ;
const int N = 1010;
int num[N], cnt ;
LL f[N] , n;
void init() {
    f[0] = 0 ; f[1] = 3 ;
    for( int i = 2 ; i <= 11 ; ++i ) f[i] = f[i-1] * 4 ;
}
LL cal( int pos ) {
    if( pos == 1 ) {
        return min ( 3LL , (LL)num[pos] + 1 ) ;
    }
    else {
        if( num[pos] <= 3 ) return f[ pos-1 ] * num[pos] + cal( pos - 1 ) ;
        else return f[pos] ;
    }
}
int main()
{
//    freopen("in.txt","r",stdin);
    ios::sync_with_stdio(false);
    init();
    while( cin >> n ) {
        if( !n ){ puts("0"); continue ; }
        if( n == 1  ){ puts("1"); continue ; }
        n--; cnt = 1 ;
        while( n ) {
            num[cnt++] = n % 10 ;
            n /= 10 ;
        }
        cout << cal( cnt - 1 ) << endl ;
    }
}
View Code

优质内容筛选与推荐>>
1、Java---SSH(MVC)面试题
2、Delphi杂项
3、排序之选择排序
4、一道经典的SQL面试题
5、java 利用Class获取类的属性信息


长按二维码向我转账

受苹果公司新规定影响,微信 iOS 版的赞赏功能被关闭,可通过二维码转账支持公众号。

    阅读
    好看
    已推荐到看一看
    你的朋友可以在“发现”-“看一看”看到你认为好看的文章。
    已取消,“好看”想法已同步删除
    已推荐到看一看 和朋友分享想法
    最多200字,当前共 发送

    已发送

    朋友将在看一看看到

    确定
    分享你的想法...
    取消

    分享想法到看一看

    确定
    最多200字,当前共

    发送中

    网络异常,请稍后重试

    微信扫一扫
    关注该公众号





    联系我们

    欢迎来到TinyMind。

    关于TinyMind的内容或商务合作、网站建议,举报不良信息等均可联系我们。

    TinyMind客服邮箱:support@tinymind.net.cn