hdoj--2955--Robberies(背包好题)


Robberies

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17709Accepted Submission(s): 6539



Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05

Sample Output
2 4 6

Source
IDI Open 2009


刚开始一直用概率作条件判断,但是一直错,后来听别人建议,就改成了钱作条件,背包里存入概率,但是同时发生的事情概率应该相乘

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define MAX(a,b)(a>b?a:b)
int main()
{
	int T, i, j, n, money[110];
	float P, p[110], dp[10010];
	int k=1;
	scanf("%d",&T);
	while(T--)
	{
		memset(dp,0,sizeof(dp));
		int sum = 0;
		scanf("%f%d",&P,&n);
		P=1-P;
		for(i=1;i<=n; i++)
		{
			scanf("%d%f",&money[i],&p[i]);
			sum += money[i];
			p[i] =(1-p[i]);
		}
		dp[0] = 1;
		for(int i=1;i<=n;i++)
		{
			for(int j=sum;j>=money[i];j--)
			{
				dp[j]=MAX(dp[j],dp[j-money[i]]*p[i]);
			}
		}
		int i;
		for(i=sum;i>=0;i--)
		{
			if(dp[i]>=P)
			break;
		}
		printf("Case %d: %d\n",k++,i);
	}
	return 0;
}


优质内容筛选与推荐>>
1、按钮的两次点击事件
2、Android自动化系列--Athrun框架原理初步探索
3、函数:将一根线段Segment转化为Polyline
4、部署tomcat环境
5、Durandal介绍


长按二维码向我转账

受苹果公司新规定影响,微信 iOS 版的赞赏功能被关闭,可通过二维码转账支持公众号。

    阅读
    好看
    已推荐到看一看
    你的朋友可以在“发现”-“看一看”看到你认为好看的文章。
    已取消,“好看”想法已同步删除
    已推荐到看一看 和朋友分享想法
    最多200字,当前共 发送

    已发送

    朋友将在看一看看到

    确定
    分享你的想法...
    取消

    分享想法到看一看

    确定
    最多200字,当前共

    发送中

    网络异常,请稍后重试

    微信扫一扫
    关注该公众号





    联系我们

    欢迎来到TinyMind。

    关于TinyMind的内容或商务合作、网站建议,举报不良信息等均可联系我们。

    TinyMind客服邮箱:support@tinymind.net.cn