POJ 1789 权值为字符串差值的最小生成树


Truck History
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 24751 Accepted: 9647

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.


变相求最小生成树,两个点之间权值为两个字符串不同字符的个数,求最小生成树权值的倒数

#include<cstdio>
#include<algorithm>
#include <iostream>
using namespace std;

const int maxn = 2000+10;
char map[maxn][10];
int f[maxn];
int n,cnt;

struct edge{
    int u,v;
    int w;
}e[maxn*maxn/2];

int dist(int st, int en)
{
    int distance = 0;
    for(int i = 0; i < 7; i++)
        if(map[st][i] != map[en][i])
            distance++;
    return distance;
}

bool cmp(edge a, edge b)
{
    return a.w < b.w;
}

int find(int x)
{
    return x == f[x] ? x : f[x] = find(f[x]);
}


int Kruskal()
{
    int ans = 0;
    for(int i = 1; i <= n; i++) f[i] = i;
    sort(e,e+cnt,cmp);

    for(int i = 0; i < cnt; i++)
    {
        int u = find(e[i].u);
        int v = find(e[i].v);

        if(u != v)
        {
            f[v] = u;
            ans += e[i].w;
        }
    }
    return ans;
}
int main()
{
    while(scanf("%d", &n) != EOF)
    {
        if(n == 0) break;
        for(int i = 1; i <= n; i++)
            scanf("%s", map[i]);

        cnt = 0;
        for(int i = 1; i < n; i++)
        {
            for(int j = i+1; j <= n; j++)
            {
                e[cnt].u = i;
                e[cnt].v = j;
                e[cnt].w = dist(i,j); //把字符串差值变权值
                cnt++;
            }
        }

        int ans = Kruskal();
        printf("The highest possible quality is 1/%d.\n", ans);
    }
    return 0;
}



优质内容筛选与推荐>>
1、幸福框架:元数据驱动界面,支持三级配置(生成期、运行期和开发期)
2、LINUX命令—让人喜爱的find
3、sturt2步骤
4、前20名的不安全密码(需要避免)
5、Redis安装及HA(High Availability)配置


长按二维码向我转账

受苹果公司新规定影响,微信 iOS 版的赞赏功能被关闭,可通过二维码转账支持公众号。

    阅读
    好看
    已推荐到看一看
    你的朋友可以在“发现”-“看一看”看到你认为好看的文章。
    已取消,“好看”想法已同步删除
    已推荐到看一看 和朋友分享想法
    最多200字,当前共 发送

    已发送

    朋友将在看一看看到

    确定
    分享你的想法...
    取消

    分享想法到看一看

    确定
    最多200字,当前共

    发送中

    网络异常,请稍后重试

    微信扫一扫
    关注该公众号





    联系我们

    欢迎来到TinyMind。

    关于TinyMind的内容或商务合作、网站建议,举报不良信息等均可联系我们。

    TinyMind客服邮箱:support@tinymind.net.cn