POJ3528:River Hopscotch(二分)


River Hopscotch
Time Limit:2000MS Memory Limit:65536K
Total Submissions:12487 Accepted:5353

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end,Lunits away from the start (1 ≤L≤ 1,000,000,000). Along the river between the starting and ending rocks,N(0 ≤N≤ 50,000) more rocks appear, each at an integral distanceDifrom the start (0 <Di<L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up toMrocks (0 ≤MN).

FJ wants to know exactly how much he can increase the shortest distance*before*he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set ofMrocks.

Input

Line 1: Three space-separated integers:L,N, andM
Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removingMrocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

Source

USACO 2006 December Silver 题意:一条河宽L米,有N个石头与流水方向垂直排成直线,每个石头离岸边的距离给出,任务是最大化去除M块石头后 石石间距与石岸间距的最短距离。

思路:将最小的间距与最大的间距为上下界进行间距的二分,判断能否通过去除M块石头达到该种间距,要处理好判断条件和二分边界的对应。

# include <stdio.h>
# include <algorithm>
using namespace std;
int main()
{
    int L, N, M, a[50002], imin;
    while(~scanf("%d%d%d",&L,&N,&M))
    {
        a[0] = 0;
        a[N+1] = L;
        for(int i=1; i<=N; ++i)
            scanf("%d",&a[i]);
        ++N;
        sort(a, a+N);
        imin = a[1] - a[0];
        for(int i=2; i<=N; ++i)
            imin = min(imin, a[i]-a[i-1]);
        int l = imin;
        int r = L;
        while(l<r)
        {
            int sum=0, cnt=0, mid = (l+r)>>1;
            for(int i=1; i<=N; ++i)
            {
                sum += a[i]-a[i-1];
                if(sum <= mid)//猜测目标间距可能大于MID,因此小于等于MID间距的都要去一块石头。
                    ++cnt;
                else
                    sum = 0;
            }
            if(cnt <= M)//能达到要求,即目标间距一定比MID大。
                l = mid+1;
            else//达不到要求,目标间距可能比MID小或等于MID。
                r = mid;
        }
        printf("%d\n",r);
    }
    return 0;
}



优质内容筛选与推荐>>
1、基于Map的用户注册、登录、抽奖系统
2、eclipse快捷键
3、图——图的邻接链表存储结构
4、用 WB Editor 连接 cnblogs.com 的全攻略[yysun]
5、Java - 打印质数(使用控制嵌套循环跳转)


长按二维码向我转账

受苹果公司新规定影响,微信 iOS 版的赞赏功能被关闭,可通过二维码转账支持公众号。

    阅读
    好看
    已推荐到看一看
    你的朋友可以在“发现”-“看一看”看到你认为好看的文章。
    已取消,“好看”想法已同步删除
    已推荐到看一看 和朋友分享想法
    最多200字,当前共 发送

    已发送

    朋友将在看一看看到

    确定
    分享你的想法...
    取消

    分享想法到看一看

    确定
    最多200字,当前共

    发送中

    网络异常,请稍后重试

    微信扫一扫
    关注该公众号





    联系我们

    欢迎来到TinyMind。

    关于TinyMind的内容或商务合作、网站建议,举报不良信息等均可联系我们。

    TinyMind客服邮箱:support@tinymind.net.cn