POJ 1573 (13.10.11)


Description


A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

题意: 不难理解, 我简单说说, 给出r行c列, 然后从第一行的第i个位置开始走

每个位置有标记E W S N, 分别表示向东, 向西, 向南, 向北

然后, 有两种情况, 一种能走出去, 一种是陷入死循环


做法: 每一步都标上是第几步走的就OK了~ 然后按题意模拟~


AC代码:

#include<stdio.h>

char str[100][100];

int main() {
    int r, c, in;
    while(scanf("%d %d %d", &r, &c, &in) != EOF) {
        if(r == 0 && c ==0 && in == 0)
            break;
        getchar();
        for(int i = 0; i < r; i++)
            gets(str[i]);
        int tr, tc, loop;
        int step = 0;
        int mark = 1;
        tr = 0; tc = in-1;

        while(1) {
            if(str[tr][tc] == 'E') {
                step++;
                str[tr][tc] = step + '0';
                if(tc == c-1)
                    break;
                else
                    tc = tc + 1;
            }
            else if(str[tr][tc] == 'W') {
                step++;
                str[tr][tc] = step + '0';
                if(tc == 0)
                    break;
                else
                    tc = tc - 1;
            }
            else if(str[tr][tc] == 'S') {
                step++;
                str[tr][tc] = step + '0';
                if(tr == r-1)
                    break;
                else
                    tr = tr + 1;
            }
            else if(str[tr][tc] == 'N') {
                step++;
                str[tr][tc] = step + '0';
                if(tr == 0)
                    break;
                else
                    tr = tr - 1;
            }
            else {
                mark = 0;
                loop = str[tr][tc] - '0' - 1;
                printf("%d step(s) before a loop of %d step(s)\n", loop, step - loop);
                break;
            }
        }
        if(mark == 1)
            printf("%d step(s) to exit\n", step);
    }
    return 0;
}

优质内容筛选与推荐>>
1、win10环境下mysql5.7压缩包解压安装过程
2、华为牛人在华为工作十年的感悟!(有点长)(转载)
3、php 安装 swoole
4、#敏捷个人# 每日成长101:第73天【选择】
5、2008/5/10


长按二维码向我转账

受苹果公司新规定影响,微信 iOS 版的赞赏功能被关闭,可通过二维码转账支持公众号。

    阅读
    好看
    已推荐到看一看
    你的朋友可以在“发现”-“看一看”看到你认为好看的文章。
    已取消,“好看”想法已同步删除
    已推荐到看一看 和朋友分享想法
    最多200字,当前共 发送

    已发送

    朋友将在看一看看到

    确定
    分享你的想法...
    取消

    分享想法到看一看

    确定
    最多200字,当前共

    发送中

    网络异常,请稍后重试

    微信扫一扫
    关注该公众号





    联系我们

    欢迎来到TinyMind。

    关于TinyMind的内容或商务合作、网站建议,举报不良信息等均可联系我们。

    TinyMind客服邮箱:support@tinymind.net.cn