A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2,
..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length
common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard
output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0
题目没看完 看了一下样例 估计是最长公共子序列。。
虽然水题 还是记不牢 写一遍
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <ctime>
#include <algorithm>
#include <iostream>
#include <sstream>
#include <string>
#define oo 0x13131313
using namespace std;
char A[1001],B[1001];
int F[1000][1000];
void solve()
{
memset(F,0,sizeof(F));
int lena=strlen(A);
int lenb=strlen(B);
F[0][0]=0;
F[0][1]=0;
F[1][0]=0;
for(int i=1;i<=lena;i++)
for(int j=1;j<=lenb;j++)
{
if(A[i-1]==B[j-1])
F[i][j]=F[i-1][j-1]+1;
else F[i][j]=max(F[i][j-1],F[i-1][j]);
}
printf("%d\n",F[lena][lenb]);
}
int main()
{
while(scanf("%s %s",A,B)!=EOF)
{
solve();
}
return 0;
}
优质内容筛选与推荐>>
1、spring boot: Annotation 注解之@Target的用法介绍2、linux TOP命令各参数详解【转载】3、模仿jQuery的ajax的封装4、linux下如何限制普通用户更改密码5、ios开发下的点透处理
长按二维码向我转账
受苹果公司新规定影响,微信 iOS 版的赞赏功能被关闭,可通过二维码转账支持公众号。
阅读
好看
已推荐到看一看
![]()
你的朋友可以在“发现”-“看一看”看到你认为好看的文章。
取消
分享想法到看一看
确定
最多200字,当前共字
微信扫一扫
关注该公众号