hdu1019 Least Common Multiple


Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input
2 3 5 7 15 64 10296 936 1287 792 1

Sample Output
105 10296 橙子教我的黑科技直接用__gcd求最小公约数
#include<iostream>
#include<algorithm> 
using namespace std;
int main()
{
    int n;
    int sum,m,a;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d",&m);
             sum=1;
        while(m--)
        {
            scanf("%d",&a);
            sum=sum/__gcd(sum,a)*a;
        }
        printf("%d\n",sum);
    }
    return 0;
}

优质内容筛选与推荐>>
1、输出一个六位的随机验证码
2、COGS738 [网络流24题] 数字梯形(最小费用最大流)
3、linux shell cut 命令
4、mac下使用mono运行Fiddler!!
5、【转】Lesktop 1.0 ——开源JS控件库,WebIM和网盘


长按二维码向我转账

受苹果公司新规定影响,微信 iOS 版的赞赏功能被关闭,可通过二维码转账支持公众号。

    阅读
    好看
    已推荐到看一看
    你的朋友可以在“发现”-“看一看”看到你认为好看的文章。
    已取消,“好看”想法已同步删除
    已推荐到看一看 和朋友分享想法
    最多200字,当前共 发送

    已发送

    朋友将在看一看看到

    确定
    分享你的想法...
    取消

    分享想法到看一看

    确定
    最多200字,当前共

    发送中

    网络异常,请稍后重试

    微信扫一扫
    关注该公众号





    联系我们

    欢迎来到TinyMind。

    关于TinyMind的内容或商务合作、网站建议,举报不良信息等均可联系我们。

    TinyMind客服邮箱:support@tinymind.net.cn