HDU 3172 Virtual Friends (并查集)


Virtual Friends

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2964 Accepted Submission(s): 861


Problem Description
These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends.

Your task is to observe the interactions on such a website and keep track of the size of each person's network.

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.

Input
Input file contains multiple test cases.
The first line of each case indicates the number of test friendship nest.
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).

Output
Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.

Sample Input
1 3 Fred Barney Barney Betty Betty Wilma

Sample Output
2 3 4


题意:问你就是到每句话的这两个人的朋友网里面有多少人

思路: 并查集

import java.util.*;
import java.io.*;

public class Main {
	int M = 100000;
	int n, m;
	HashMap<String, Integer> hm = new HashMap<String, Integer>();//用来给字符串编号
	int patten[] = new int[M + 1];
	int ans[] = new int[M + 1];

	public static void main(String[] args) {
		new Main().work();
	}

	void work() {
		Scanner sc = new Scanner(new BufferedInputStream(System.in));
		while (sc.hasNext()) {
			hm.clear();
			n = sc.nextInt();
			for (int j = 0; j < n; j++) {
				//并查集初始化
				for (int i = 1; i <=M; i++) {
					patten[i] = i;
				}
				Arrays.fill(ans, 1);
				m = sc.nextInt();
				int count = 1;
				for (int i = 0; i < m; i++) {
					String s1 = sc.next();
					String s2 = sc.next();
					if (!hm.containsKey(s1)) {
						hm.put(s1, count);
						count++;
					}
					if (!hm.containsKey(s2)) {
						hm.put(s2, count);
						count++;
					}
					union(hm.get(s1), hm.get(s2));

				}
			}
		}
	}
	//并查集合并
	void union(int a, int b) {

		int pa = find(a);
		int pb = find(b);
		if (pa == pb) {
			System.out.println(ans[pa]);
			return;
		}
		if(pa>pb){
			patten[pb]=pa;
			ans[pa]+=ans[pb];
			System.out.println(ans[pa]);
		}
		else{
			patten[pa]=pb;
			ans[pb]+=ans[pa];
			System.out.println(ans[pb]);
		}
	}
	//并查集查找
	int find(int x) {
		if(patten[x]==x)
			return x;
		int t=patten[x];
		patten[x]=find(t);//路径优化
		return patten[x];
	}
}



优质内容筛选与推荐>>
1、无人驾驶书籍推荐
2、Activity的生命周期 (必须掌握)
3、BTree,B-Tree,B+Tree,B*Tree都是什么
4、WCF
5、写一个Email地址校验程序


长按二维码向我转账

受苹果公司新规定影响,微信 iOS 版的赞赏功能被关闭,可通过二维码转账支持公众号。

    阅读
    好看
    已推荐到看一看
    你的朋友可以在“发现”-“看一看”看到你认为好看的文章。
    已取消,“好看”想法已同步删除
    已推荐到看一看 和朋友分享想法
    最多200字,当前共 发送

    已发送

    朋友将在看一看看到

    确定
    分享你的想法...
    取消

    分享想法到看一看

    确定
    最多200字,当前共

    发送中

    网络异常,请稍后重试

    微信扫一扫
    关注该公众号





    联系我们

    欢迎来到TinyMind。

    关于TinyMind的内容或商务合作、网站建议,举报不良信息等均可联系我们。

    TinyMind客服邮箱:support@tinymind.net.cn