Period
Time Limit:3000MS Memory Limit:30000K
Total Submissions:22012 Accepted:10679

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

思路:和poj-2406思路相同。
#include <iostream>
#include<string.h>
using namespace std;
const int maxn = 1e6+10;
char a[maxn];
int ne[maxn];
int main()
{
    int n;
    int num=0;
    while(scanf("%d",&n)&&n!=0)
    {
        memset(ne,0,sizeof(ne));
        scanf("%s",a+1);
        for(int i=2,j=0;i<=n;i++)
        {
            while(j&&a[i]!=a[j+1]) j=ne[j];
            if(a[i]==a[j+1]) j++;
            ne[i]=j;
        }
        printf("Test case #%d\n",++num);
        for(int i=2;i<=n;i++)
        {
            if(i%(i-ne[i])==0&&ne[i]>0)       //ne[i]>0判断没有循环节的情况
            {
                printf("%d %d\n",i,i/(i-ne[i]));
            }
        }
        printf("\n");
    }
    return 0;
}

优质内容筛选与推荐>>
1、Problem C: [noip2016十连测第五场]travel (构造+贪心)
2、.net core i上 K8S(一)集群搭建
3、【日语】日语一级句型强记
4、今天开始编图书管理系统,适应一下C#
5、ORM简单增删改查


长按二维码向我转账

受苹果公司新规定影响,微信 iOS 版的赞赏功能被关闭,可通过二维码转账支持公众号。

    阅读
    好看
    已推荐到看一看
    你的朋友可以在“发现”-“看一看”看到你认为好看的文章。
    已取消,“好看”想法已同步删除
    已推荐到看一看 和朋友分享想法
    最多200字,当前共 发送

    已发送

    朋友将在看一看看到

    确定
    分享你的想法...
    取消

    分享想法到看一看

    确定
    最多200字,当前共

    发送中

    网络异常,请稍后重试

    微信扫一扫
    关注该公众号





    联系我们

    欢迎来到TinyMind。

    关于TinyMind的内容或商务合作、网站建议,举报不良信息等均可联系我们。

    TinyMind客服邮箱:support@tinymind.net.cn